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Introducing ABBYY FlexiCapture
ABBYY FlexiCapture is a highly scalable platform for intelligent data and document capture which can
be successfully used to extract data from unstructured as well as structured paper documents, scans,
e-mail messages, and other sources for subsequent use in document management systems. The four
basic data extraction operations in ABBYY FlexiCapture include classification, optical recognition,
verification, and export to ERP, ECM or BPM systems. 

ABBYY FlexiCapture is capable of handling the full range of data processing needs, from small-scale
projects to distributed industrial capture of large volumes of data, providing high levels of security and
reliability expected from enterprise-grade software solutions.

The basic document processing scenario is as follows:

1. Documents are placed in the automatic scanner feeder and scanning begins. Images can also be
imported from email or a mobile device, etc.

2. Scanned document images are submitted for recognition, at which point the software
automatically identifies documents, including multipage documents, locates meaningful fields,
extracts data and loads check rules.

3. After the recognition has been completed the extracted data undergoes an automatic check rules.
If necessary, the process of visual check for data and rule errors is launched.

4. Recognized and verified data along with electronic copies of documents are saved to a database,
an information system, or a file.

ABBYY FlexiCapture architecture
ABBYY FlexiCapture is a set of applications that comprises document processing stations and
servers.

Server components:

1. Application Server is a web service in Internet Information Services (IIS) which functions as the
main gateway for all HTTP/HTTPS traffic in the system . This component provides user
authentication and authorization functionality and enables communication between the server and
client components.

2. License Server is a service that stores information about the current license and allowed uses
of the system.

3. Processing Server is service that manages the Processing Stations. This component enables
distributed processing.

4. Database stores the processing settings, information about the users, information about the
documents that are being processed, and statistics for the documents that have been processed.

5. File Storage stores the images of the documents that are being processed and the data
captured from these documents.

Each server component can be installed on a separate computer, allowing variable scalability and
individual reliability and security settings.
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Client components:

1. Administration and Monitoring Console is a web application that is used for setting up ABBYY
FlexiCapture and monitoring its operation.

2. Project Setup Station is used for setting up document processing.

3. Processing Stations:

o Automated Processing Stations import and process images, perform optical recognition, run
user scripts, export extracted data to the user's storage system, and perform a number of
service operations.

o Manual Processing Stations (Scanning Station and Verification Station) is a set of
applications for obtaining document images,  feeding them to ABBYY FlexiCapture, and verifying
extracted data. They can be installed as separate PC applications, as thin browser-based
clients, or as mobile apps. 

Component interaction

The flow chart below illustrates interaction among the ABBYY FlexiCapture components.

For details, see: Overview of interactions between ABBYY FlexiCapture components.

By default, the following ports and protocols are used:

· Application Server - 80 (if HTTP is used) or 443 (if HTTPS is used)

http://knowledgebase.abbyy.com/article/1951
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· License Server - 3020

· Processing Server - 10024

· Processing Stations - 10025

See also: How to change the ports used by ABBYY FlexiCapture.

Express Installation and Setup
Important! This section describes installing and setting up ABBYY FlexiCapture on a stand-alone
computer for evaluation and demonstration purposes. Distributed installation is recommended for
industrial document and data capture.

System requirements
CPU 2.4 GHz or faster 4-core CPU

Operating System

· Windows 7 SP1

· Windows 8.1

· Windows 10

· Windows Server 2008 SP2 + Desktop Experience

· Windows Server 2008 R2 SP1 + Desktop Experience

· Windows Server 2012 + Desktop Experience

· Windows Server 2012 R2 + Desktop Experience

· Windows Server 2016 + Desktop Experience 

Note: To use a localized version of ABBYY FlexiCapture, make sure your
operating system supports the corresponding GUI language. 

RAM 8 GB 

Disk space 20 GB for installation and temporary files + 10 GB for the Database and File
Storage

System and
software
components

1. Internet Information Services (IIS) 7 or later

2. Microsoft .NET Framework 4.5 or later (4.6 if you use Windows 10)

Note: Windows 2012R2 already includes .Net Framework 4.5.1 but you will need
to install ASP.NET 4.5. You can look up the version of your .Net Framework in the
registry. Please visit this Microsoft web page for detailed instructions.

3. Microsoft SQL Server 2008 SP4, 2008 R2 SP3, 2012 SP2, 2014 SP1, 2016

4. Visual C++ 2015 Redistributable

http://knowledgebase.abbyy.com/article/1873
https://support.microsoft.com/en-us/help/318785/how-to-determine-which-versions-and-service-pack-levels-of-the-microsoft-.net-framework-are-installed
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Other
requirements

A scanner with TWAIN, WIA or ISIS support

Installation
Important! Before installing and setting up ABBYY FlexiCapture, be sure to disable UAC (User Account
Control). Alternatively, you can install Application Server using the built-in administrator account.

To install and set up the server components of ABBYY FlexiCapture, you must first install Internet
Information Services (IIS), Microsoft .NET Framework, and Microsoft SQL Server. 

Internet Information Services (IIS) and Microsoft .NET Framework are installed via the Server Manager
console (Start → All programs → Administrative Tools → Server Manager):

1. In Server Manager, click Add roles and features.

2. In the Server Roles list, select Web Server (IIS). 

If IIS is already installed on your computer, make sure that the following IIS components are selected:

Web Management Tools
· IIS 6 Management Compatibility
o IIS Scripting Tools
o IIS 6 WMI Compatibility
o IIS Metabase and IIS 6 configuration compatibility

· IIS Management Console
World Wide Web Services
· Application Development Features
o .NET Extensibility
o ASP.NET
o ISAPI Extensions
o ISAPI Filters

· Common HTTP Features
o Default Document
o HTTP Errors
o HTTP Redirection
o Static Content

· Security
o Basic Authentication
o Request Filtering
o Windows Authentication

Note: You can additionally install any other IIS components that you need or install IIS in its entirety.

In the Features list, select .NET Framework 4.5 Features and make sure that the following
components are selected:

· .NET Framework (includes .NET 2.0 and 3.0)
· .NET Framework 4.5 Advanced Services
o ASP.NET 4.5
o WCF Services

§ TCP Port Sharing

Microsoft SQL Server can be installed from the ABBYY FlexiCapture 12 setup package:

1. Run Autorun.exe. 

2. Click 2. Distributed Installation → 1. Install External Components →  Microsoft SQL Server
2014 Express.

http://knowledgebase.abbyy.com/article/1961
http://knowledgebase.abbyy.com/article/1961
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3. When installing Microsoft SQL Server, specify the following:

o Named instance: e.g., SQLExpress;

o Authentication Mode: Mixed Mode (SQL Server authentication and Windows authentication);

o The password for the SQL Server system administrator (sa) account and SQL Server
administrators.

Installing servers

To install ABBYY FlexiCapture servers:

1. On the Autorun menu, click 2. Distributed Installation → 2. Install Servers and follow the
instructions of the install wizard.

2. In the Custom Setup dialog box, select the following components:

· Processing Server

· Protection Server

· Application Server

o Web Stations

Finally, specify a destination folder.

Once the setup is finished, the following will be launched automatically:

· the License Manage utility, where you can activate your serial number.

· the Administration and Monitoring Console, where you can set up Application Server (see the Setup
section).

Note: You can also launch the License Manager and the Administration and Monitoring Console
manually by clicking Start → All Programs → ABBYY FlexiCapture 12 Servers.

Installing stations

To install ABBYY FlexiCapture stations:

1. On the Autorun menu, click 2. Distributed Installation → 2. Install Workstations and follow the
instructions of the setup wizard.

2. In the Custom Setup dialog box, select the components you want to install (by default, all of the
components are selected) and specify a destination folder.

3. In the Protection Server Location dialog box, keep the default value (127.0.0.1).

4. In the User account dialog box,  select this account for the processing service: Default account
(NT AUTHORITY\Network Service). 

Once ABBYY FlexiCapture is installed, it must be set up for document and data capture.
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Setup
To set up ABBYY FlexiCapture:

1. Open the Administration and Monitoring Console under a user account that has administrative
privileges. Use one of the following two methods:

· Click Start → All programs → ABBYY FlexiCapture 12 Servers → Administration and
Monitoring Console 
or

· Click this link: http://localhost/FlexiCapture12/Monitoring/#Settings/DbConn

Click Settings → Application Server and then click the Create new database button. In the
window that opens, specify the following:

Server instance name

(local)\sqlexpress

Note: If SQL Server is not installed locally, the server instance name will look like this:
<computer_name>\sqlexpress 

Database name FCDemoDataBase

Authentication
settings

Database Server Authentication

User name and
Password

The name and password of the database administrator that were specified when installing
Microsoft SQL Server (see the Installation section)

Use external file
storage

Select this option and specify the path to a file storage location for example: C:\FileStorage

Click OK. Once the database is created, you will be issued a temporary password, which is the
word "password." Please open the log-in page (http://localhost/FlexiCapture12/Login) and change
this password.

Note: For detailed instructions on creating a new database,  see the Creating a database section.

2. Set up the Processing Server: 

1. Launch the Processing Server Monitor (click Start → All Programs → ABBYY FlexiCapture 12
Servers → Processing Server);

2. On the Actions menu, click Add Server  → Local Host.

3. Make sure that the Processing Server is running (it should have  next to it). Otherwise, click
Actions → Start.

Note: For detailed instructions on setting up the Processing Server, see the Configuring the
Processing Server section.

4. To add Processing Stations: selecting the Stations item in the  ABBYY FlexiCapture 12
Servers tree,  select <Server_Name>, and then click Actions → Add Stations.... In the window
that opens, click By name... and type "localhost" to add the locally installed Processing Station.
Start the Processing Station (Actions → Start).

http://localhost/FlexiCapture12/Monitoring/DBConnection.aspx#/DBConnection?info
http://localhost/FlexiCapture12/Login
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3. Upload a project to the server:

1. Launch the Project Setup Station (click Start → All Programs → ABBYY FlexiCapture 12
Stations → Project Setup Station).

2. Open a local project (click File → Open Project...). 

Note: You can select any of the sample projects stored in this folder: %public%
\ABBYY\FlexiCapture\12.0\Samples.

3. Upload the project to the server (click File → Upload Project to Server...). Enter the address of
the Application Server in the following format: http://localhost. 

Note: If the Project Setup Station and the Application Server are installed on different computers, the
server address will look like this: http://<server_name>.

4. Select Use server authentication and enter the name and password of the database
administrator.

Note: If you are planning to demonstrate how images can be imported from Hot Folders, enable Hot
Folder processing in the Administration and Monitoring Console (click Settings → Projects).

ABBYY FlexiCapture 12 is now ready for demonstration.

If you need more information on setting up ABBYY FlexiCapture 12 or if you encounter any problems
when completing the steps listed on this page, please refer to the Deploying ABBYY FlexiCapture
section.

Deploying ABBYY FlexiCapture
Standalone and Distributed Editions

ABBYY FlexiCapture Standalone

ABBYY FlexiCapture Distributed

Standalone and Distributed Editions
ABBYY FlexiCapture is available in two editions, standalone and distributed.

ABBYY FlexiCapture 12 Standalone is installed on one computer and is intended for processing small
volumes of documents by two or three Operators who work in shifts. This edition does not support
complex batch routing schemes.

ABBYY FlexiCapture 12 Distributed is installed on multiple computers and is intended for processing
large volumes of documents in enterprise environments. This edition is highly scalable, offers
centralized control console, and supports complex routing schemes, where documents are distributed
among Operators in charge of different types of batches or documents.

There is also an option of installing ABBYY FlexiCapture 12 Distributed with basic settings on one
computer or virtual machine for evaluation and demonstration purposes.

ABBYY FlexiCapture productivity

ABBYY FlexiCapture productivity is expressed as the number of pages or documents processed within
a certain time period. The major factors affecting productivity are:

http://localhost
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1. The size of page images.

Note: Images size depends on paper size, scanning resolution, and scanning mode (i.e. whether the
image has been scanned in black-and-white, grayscale, or color).

2. The number of automated processing stations.

3. The number of Operators involved in document processing.

Note: There are two main types of Operators — Scanning Operators and Verification Operators. A
Scanning Operator scans, checks, and processes images, while a Verification Operator verifies and
corrects captured data.

Depending on your processing needs, select the optimal configuration for your system:

Pages* / 24 hours Scanning
Operators

Verification
Operators

Data transfer
rate

CPU cores

Black-and-white Grayscale Color

20,000 5,000 1,000 3 or fewer 3 or fewer - 8

1,000,000 500,000 300,000 300 100 1 Gb/sec 80

3,000,000 2,000,000 1,000,000. 1000 300 10 Gb/sec 160

* А4 pages scanned at 300 dpi.

Note: The performance indicators can vary depending on the processing settings and hardware
environment. It is recommended to execute tests in order to identify bottlenecks.

ABBYY FlexiCapture Standalone
ABBYY FlexiCapture Standalone is intended for processing documents on one computer. The program
is set up and monitored by an Administrator, while documents are scanned and captured data are
verified by Operators. Document recognition is carried out automatically.

System Requirements
CPU 2 GHz or faster

Operating system

· Windows 7 SP1

· Windows 8.1

· Windows 10

Note: To use a localized version of ABBYY FlexiCapture, make sure your
operating system supports the corresponding GUI language. 

RAM at least 2 GB

Disk space 4 GB (including 2 GB for installation)

Other
requirements

1. Microsoft .NET Framework 4.5 or later 

Note: Windows 2012R2 already includes .Net Framework 4.5.1 but you will need
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to install ASP.NET 4.5. You can look up the version of your .Net Framework in the
registry. Please visit this Microsoft web page for detailed instructions.

2. Microsoft Office (version 2007 or later) or LibreOffice (version 4.0 or later)

3. A scanner with TWAIN, WIA or ISIS support

Installation
1. On the Autorun menu, select Standalone Installation and follow the instructions of the setup

wizard.

2. In the Setup Type dialog box, select one of the available installation modes:

· Administrator Station – The Administrator Station, FormDesigner, and FlexiLayout Studio will
be installed. Select this option if you need to set up ABBYY FlexiCapture to process a specific
kind of document.

· Operator Station – Only the Operator Station will be installed. Select this option to start
processing documents as an Operator.

· Administrator and Operator Stations (selected by default) – The Administrator Station, the
Operator Station, FormDesigner, and FlexiLayout Studio will be installed. Select this option if
you need to set up to set up ABBYY FlexiCapture to process a specific kind of document and
start processing documents as an Operator.

3. Select a destination folder.

4. Click Next and wait for the installation to complete.

Installing multiple workstations with a single Licensing Server
All the stations installed in the system communicate with the Licensing Server. The address of the
Licensing Server is stored in the LicensingSettings.xml file, which can be found in the folder where you
installed the product. The address of the server is specified in the ServerAddress tag of the
MainNetworkLicenseServer attribute.

If you have one license and several Operator stations, specify the address of the computer with the
license on each Operator station. To enable a station to access the new Licensing Server, simply
change the name of the computer on which the Licensing Server is installed and restart the station.

Creating and opening projects
After you install the program, the License Manager utility will be started, prompting you to activate your
serial number.

Note: You can also start the License Manager manually by clicking Start → All Programs → ABBYY
FlexiCapture 12.

To start ABBYY FlexiCapture:

· Click Start → All Programs → ABBYY FlexiCapture 12 → Administrator Station to start the
program in Administrator mode.

https://support.microsoft.com/en-us/help/318785/how-to-determine-which-versions-and-service-pack-levels-of-the-microsoft-.net-framework-are-installed
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· Click Start → All Programs → ABBYY FlexiCapture 12. → Operator Station to start the
program in Operator mode.

To create or open a project, perform one of the following three actions on the Administrator Station: 

· Create a new project (click File → New Project…). Create or import at least one Document
Definition (click Project → Document Definitions).

· Open a sample project from %Public%\ABBYY\FlexiCapture\12.0\Samples).

· Open a project created in an earlier version of ABBYY FlexiCapture.

Make sure that your project has at least one correct and added Document Definition for which export
settings have been specified. 

ABBYY FlexiCapture Distributed
ABBYY FlexiCapture Distributed is intended for for deployment in enterprise environments.

System Requirements
Servers

CPU
Application Server: 2 GHz or faster with 2 cores

Other servers: 2 GHz or faster

Operating system

· Windows Server 2008 SP2

· Windows Server 2008 R2 SP1

· Windows Server 2012

· Windows Server 2012 R2

· Windows Server 2016

Note: To use a localized version of ABBYY FlexiCapture, make sure your
operating system supports the corresponding GUI language. 

RAM
At least 2 GB for each component

Note: An additional 4 GB RAM is required if Database Server is installed.

Disk space

1. Application Server: 500 MB for installation

2. Processing Server: 400 MB for installation

3. Licensing Server: 100 MB for installation

4. 2 GB for SQL Server database 

5. Additional space is required for the file storage 

Browser · Internet Explorer 11
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(to open
Administration and
Monitoring
Console)

Note: To ensure that Internet Explorer 11 works correctly, install .NET
Framework 4.5 on the computer with the Application Server or add the address of
an application server to the list of websites that are opened in compatibility mode.

· Mozilla Firefox 50 or later (32-bit)

· Google Chrome 55 or later (32-bit)

Other
requirements

1. The computer where the server is installed must be connected to your
domain

2. Video card and display with a resolution of 1024×768

3. Internet Information Services 7 or higher

4. Microsoft .NET Framework 4.5 or higher (4.6 if you use Windows 10)

5. Microsoft SQL Server 2008 SP4, 2008 R2 SP3, 2012 SP2, 2014 SP1, 2016

6. Visual C++ 2015 Redistributable

Stations

CPU 2 GHz or faster

Operating System

· Windows 7 SP1 

· Windows 8.1 

· Windows 10 

· Windows Server 2008 SP2 + Desktop Experience 

· Windows Server 2008 R2 SP1 + Desktop Experience 

· Windows Server 2012 + Desktop Experience 

· Windows Server 2012 R2 + Desktop Experience

·  Windows Server 2016 + Desktop Experience

Note: To use a localized version of ABBYY FlexiCapture, make sure your
operating system supports the corresponding GUI language. 

RAM

Project Setup Station, Verification Station, Data Verification Station: 2 GB

Processing Station: 512 MB for each CPU core, but at least 1 GB

Scanning Station: 1 GB

Disk space
Scanning Station: 1 GB (including 200 MB for installation and sufficient disk space
for scanned images)
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Other stations: 4 GB (including 2 GB for installation)

Other
requirements

1. A scanner with TWAIN, WIA or ISIS support

2. Video card and display with a resolution of 1024×768

3. The computer where the station is installed must be connected to your
domain

4. Microsoft .NET Framework 4.5 or later

5. Microsoft Office (version 2007 or later) or LibreOffice (version 4.0 or later) 

HTML 5 Web Stations (new)

CPU 1.6 GHz or faster

Operating System

· Windows 7 SP1 

· Windows 8/8.1 

· Windows 10 

· Windows Server 2008 R2 SP1 + Desktop Experience 

· Windows Server 2012 + Desktop Experience 

· Windows Server 2012 R2 + Desktop Experience

·  Windows Server 2016 + Desktop Experience

Note: To use a localized version of ABBYY FlexiCapture, make sure your
operating system supports the corresponding GUI language. 

RAM 1 GB

Disk space

· Sufficient space to install a browser 

· At least 100 MB for program operation

· An additional 60 MB is required to install the ABBYY Scanning plugin for the
Web Scanning Station.

Browser

· Microsoft Internet Explorer 11
Browser security settings: Internet Explorer medium-high protection level.
Detailed required settings for Internet Explorer: 

1. Run ActiveX controls and plugins = Enable

2. Script ActiveX controls marked safe for scripting = Enable

3. Active scripting = Enable
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Note: To ensure that Internet Explorer 11 works correctly, install .NET
Framework 4.5 on the computer with the Application Server or add the address of
an application server to the list of websites that are opened in compatibility mode.

Note: The Metro-style version of Internet Explorer 10 that comes with Windows
8 is not supported.

· Mozilla Firefox 50 or later (32-bit)
Security settings for Mozilla Firefox: 

1. Java scripting = Enable

2. Firefox will remember history (Options → Privacy)

· Google Chrome 55 or later (32-bit)
Security settings for Google Chrome: 

1. JavaScript = Allow all sites

2. plugins = Run automatically

Note: All plugins are disabled by default. To enable a plugin, open
chrome://plugins/ in the browser and select the Always allowed option for the
desired plugin.

Other
requirements

1. Video card and display with a resolution of 1024×768

2. For Web Scanning Station:

a. A scanner supporting the TWAIN interface. WIA scanners can be
accessed from the station but they may not operate properly

b. ABBYY Scanning plugin (see below)

SilverLight Web Stations (previous version)

CPU 1.6 GHz or faster

Operating System

· Windows 7 SP1 

· Windows 8/8.1 

· Windows 10 

· Windows Server 2008 R2 SP1 + Desktop Experience 

· Windows Server 2012 + Desktop Experience 

· Windows Server 2012 R2 + Desktop Experience

Note: To use a localized version of ABBYY FlexiCapture, make sure your
operating system supports the corresponding GUI language. 
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RAM 512 MB

Disk space

· 250 MB to install a browser and a SilverLight

· An additional 31 MB is required to install the ABBYY Scanning plugin for the
Web Scanning Station and the Web Capture Station.

Browser

· Microsoft Internet Explorer 11
Browser security settings: Internet Explorer medium-high protection level.
Detailed required settings for Internet Explorer: 

1. Run ActiveX controls and plugins = Enable

2. Script ActiveX controls marked safe for scripting = Enable

3. Active scripting = Enable

4. File Download = Enable (to install Silverlight)

Note: To ensure that Internet Explorer 11 works correctly, install .NET
Framework 4.5 on the computer with the Application Server or add the address of
an application server to the list of websites that are opened in compatibility mode.

Note: The Metro-style version of Internet Explorer 10 that comes with Windows
8 is not supported.

Note: Internet Explorer 64-bit is only supported under Windows 7/2008+ if
Silverlight 5 is installed.

· Mozilla Firefox 50 or later (32-bit)
Security settings for Mozilla Firefox: 

1. Java scripting = Enable

2. Firefox will remember history (Options → Privacy)

· Google Chrome 40 or later (32-bit)

Note: Google Chrome 45 or later does not support Silverlight.
Security settings for Google Chrome: 

1. JavaScript = Allow all sites

2. plugins = Run automatically

Note: All plugins are disabled by default. To enable a plugin, open
chrome://plugins/ in the browser and select the Always allowed option for the
desired plugin.

Other
requirements

1. Video card and display with a resolution of 1024×768

2. Silverlight 5.1.20913 or later

Note: Microsoft Internet Explorer 11 only supports Silverlight when running
under Windows 7 SP1, Windows 8.1 or Windows 10.
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3. For Web Scanning Station and Web Capture Station: 

a. A scanner supporting the TWAIN interface. WIA scanners can be
accessed from the station but they may not operate properly

b. ABBYY Scanning plugin (see below)

ABBYY Scanning Plug-In

The table below lists the operating systems on which the ABBYY Scanning plugin can be installed with
various permissions:

ABBYY Scanning plugin

OS Permissions UAC EXE

Windows 7 SP1

Administrator
Recommended

No

User
Recommended

No

Windows Server 2008
R2 SP1

Administrator
Recommended

No

User
Recommended

No

Windows 8.1

Administrator
Recommended

No

User
Recommended

No

Windows Server 2012*

Administrator
Recommended

No

User
Recommended

No

Windows Server 2012
R2

Administrator Recommended



18

ABBYY FlexiCapture Administrator`s guide

ABBYY Scanning plugin

OS Permissions UAC EXE

No

User
Recommended

No

Windows 10

Administrator
Recommended

No

User
Recommended

No

Note: To allow the ABBYY Scanning plugin to be installed on Windows Server 2012, run the
executable file Setup.exe as Administrator or change the security policy by setting the value of the
registry key HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer DisableMSI to “0”. 

For detailed instructions on how to install the ABBYY Scanning plugin, see Web Scanning Station Help
or Web Capture Station Help.

Remote Verification Station

CPU 2 GHz or faster

Operating System

· Windows 7 SP1 

· Windows 8.1 

· Windows 10 

· Windows Server 2008 SP2 + Desktop Experience 

· Windows Server 2008 R2 SP1 + Desktop Experience 

· Windows Server 2012 + Desktop Experience 

· Windows Server 2012 R2 + Desktop Experience 

· Windows Server 2016 + Desktop Experience

Note: To use a localized version of ABBYY FlexiCapture, make sure your
operating system supports the corresponding GUI language. 

RAM 1 GB

Disk space 400 MB
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Other
requirements

1. Video card and display with a resolution of 1024×768

2. Microsoft .NET Framework 4.5 or later

ClickOnce Scanning Station

CPU 2 GHz or faster

Operating System

· Windows 7 SP1 

· Windows 8.1 

· Windows 10 

· Windows Server 2008 SP2 + Desktop Experience 

· Windows Server 2008 R2 SP1 + Desktop Experience 

· Windows Server 2012 + Desktop Experience 

· Windows Server 2012 R2 + Desktop Experience 

· Windows Server 2016 + Desktop Experience 

Note: To use a localized version of ABBYY FlexiCapture, make sure your
operating system supports the corresponding GUI language. 

RAM 1 GB

Disk space 1 GB (including 90 MB for installation and sufficient space for scanned images).
The size of downloadable file is 70 MB

Browser

For ClickOnce deployment:

· Internet Explorer 11 

Note: To ensure that Internet Explorer 11 works correctly, install .NET
Framework 4.5 on the computer with the Application Server or add the address of
an application server to the list of websites that are opened in compatibility mode.

Other
requirements

1. A scanner with TWAIN, WIA or ISIS support

2. Video card and display with a resolution of 1024×768

3. Microsoft .NET Framework 4.5 or later

Virtual Environments

The system has been tested on the following virtual machines: 

1. Virtual platforms that imitate physical machines:
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o VMWare Workstation (any version)

o Hyper-V (any version)

Note: Hyper-V version corresponds to the version of the operating system. Under Windows Server
2008, Hyper-V 6.0 is used.

Note: Hyper-V virtual machines do not work with USB devices.

o Oracle VirtualBox (any version)

o VMWare ESXi (server included with VMWare vSphere, any version)

2. Virtual platforms imitating workplaces / applications:

o VMWare Horizon 5.2.0

o Citrix XenApp 7.13

3. Cloud services:

o Microsoft Azure

o Amazon Cloud

Preparing to install the Application Server
Important! We recommend either disabling User Account Control before installing ABBYY

FlexiCapture or performing all setup actions using the built-in administrator account.
Net Framework 4.5 and Internet Information Services must be installed on your computer before you can
install the Application Server.

Note: Windows 2012 R2 includes .Net Framework 4.5.1 but you will still need to install ASP.NET 4.5.
Please visit the Microsoft website for instructions on how to find out which Microsoft .Net Framework
versions and updates are installed on your computer.

IIS and .Net Framework are installed via the Control Panel (see the step-by-step instructions and
installation options). In the Add Roles Wizard, select the following components:

http://knowledgebase.abbyy.com/article/1961
https://technet.microsoft.com/en-us/library/hh831475.aspx
https://technet.microsoft.com/en-us/library/hh831475.aspx
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Web Management Tools
· IIS 6 Management Compatibility
o IIS Scripting Tools
o IIS 6 WMI Compatibility
o IIS Metabase and IIS 6 configuration compatibility

· IIS Management Console
World Wide Web Services
· Application Development Features
o .NET Extensibility
o ASP.NET
o ISAPI Extensions
o ISAPI Filters

· Common HTTP Features
o Default Document
o HTTP Errors
o HTTP Redirection
o Static Content

· Security
o Basic Authentication
o Request Filtering
o Windows Authentication

Other IIS components may be installed if required, e.g. you can install IIS in its entirety.

When you install the ABBYY FlexiCapture servers, the following third-party components will be installed
automatically:

1. Microsoft Visual C++ 2015 Runtime

2. Microsoft Core XML Services (MSXML6) – The Application Server requires this component for
its operation.

3. Microsoft Report Viewer 2015 Runtime – This component is used by ABBYY FlexiCapture for
generating reports.

Note: If Crystal Reports v. 13.0.11.1467 and above is installed on the computer where the Application
Server is installed, you can use this application to create reports in the Administration and Monitoring
Console.

4. Codemeter Runtime – This component is required if you plan to use a license stored on a
CodeMeter USB dongle manufactured by Wibu-Systems.

Installing the servers
Important! In enterprise environments, do not install the Processing Station on the same computer

where the ABBYY FlexiCapture servers are installed, as this will degrade server performance.

After you have completed the preparation steps, install the ABBYY FlexiCapture servers. To do this, click
Distributed Installation → Install Servers on the Autorun menu and follow the instructions of the
setup wizard.

By default, all of the servers are installed on one computer:

· Processing Server is the server that controls the Processing Stations.

· Licensing Server is the server used for storing and managing licenses.

· Application Server is the server that controls the operation of the remaining components and, in
particular:

http://msdn.microsoft.com/ru-ru/library/bb126227.aspx
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o Web stations, which allow Operators to connect to the server and process documents in the
browser window, without installing ABBYY FlexiCapture on their machines. 

If required, ABBYY FlexiCapture servers can be installed on different computers. To do this, in the 
Setup Type dialog box clear the boxes next to the servers that you do not want to install on this
computer. When installing servers on different computers, note the following:

1. The Licensing Server address should be specified in the format "server" (without \\ or http://), or
you can specify its IP address.

2. The Application Server address should be specified in the format "http://server".

Important! To be able to use remote stations over the Internet, make sure that the Application Server
is accessible over the Internet. 
See also: Silent installation.

Database server
The Application Server requires Microsoft SQL Server for its operation (for a list of supported versions,
see the System requirements section). Mixed Mode must be enabled in Microsoft SQL Server  ("SQL
Server and Windows authentication"). 

Note: The ABBYY FlexiCapture setup disk includes Microsoft SQL Server 2014 Express, which can
be used only for demonstration purposes.

Required SQL Server Collation: SQL_Latin1_General_CP1_CI_AS. 

Installing stations
To install ABBYY FlexiCapture stations, click Distributed Installation → Install Workstations on the
Autorun menu and follow the instructions of the setup wizard.

By default, all the stations are installed on one computer:

1. Scanning Station scans documents and sends them to the server for further processing; 

2. Processing Station automatically recognizes, imports, and exports documents; controlled by the
Processing Server; 

3. Project Setup Station is used to set up projects on the server and local projects; 

4. Data Verification Station is used to verify uncertainly recognized characters; 

5. Verification Station is used to verify data, correct document assembly errors, and handle
exceptions; 

6. FlexiCapture Studio is a tool for creating FlexiLayouts; 

7. FormDesigner is a tool for creating forms. 

Just like the servers, the stations can be installed on the same or on different computers. 

If required, ABBYY FlexiCapture stations can be installed on different computers. To do this, in the 
Setup Type dialog box clear the boxes next to the stations that you do not want to install on this
computer. When installing stations on different computers, note the following:
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1. If Processing Station is selected, a dialog box will appear, where you must select the account
under which the Processing Station service will run. By default, the service runs under the
NETWORK SERVICE user account. If you plan to import/export data on this station from/to a
storage location with restricted user permissions, you can specify the user that has the
appropriate permissions. In this case, the Processing Station service will run under this user.

2. When installing FlexiLayout Studio, FormDesigner, Verification Station or Project Setup Station,
provide the name or the IP address of the Licensing Server in the next dialog box that opens
(specify the name without “\”, for example: MainServer).

See also: Silent installation.

Installing remote stations

Remote stations allow you to connect to ABBYY FlexiCapture servers from computers that are not part
of your LAN. Remote stations include Verification Station, Data Verification Station, and Scanning
Station. 

Remote stations can connect to the Application Server  using HTTP/HTTPS. 

To install remote stations, click Distributed Installation on the Autorun menu, click the desired remote
station, and follow the instructions of the setup wizard.

Important! If you wish to use remote stations over the Internet, the Application Server must be
accessible over the Internet and the Processing Server must be running to enable exchange of
information with the Licensing Server. If basic authentication is to be used for remote stations, basic
authentication must be allowed in IIS in Default Web Site\FlexiCapture12\Server. 

Silent installation
Installing ABBYY FlexiCapture in silent mode

In the case of silent installation, no setup dialog boxes are displayed and the program is installed in the
default configuration.

Setup.exe/qn

Change “/qn” to “/qb” if you want an installation progress bar to be displayed. No other dialog boxes will
be displayed.

Additional command line options

/L<language code> disables the automatic selection of the GUI language and installs the program with
the interface language of your choice.

The following language code values can be specified:

1033 English

1049 Russian

/V<command line> passes the command line directly to msiexec.exe. The <command line> string can
be replaced with the following commands:

ADDLOCAL= ApplicationServer,WebStations,ProcessingServer,ProtectionServer,



24

ABBYY FlexiCapture Administrator`s guide

where:

1. ApplicationServer stands for the Application Server

2. WebStations stands for web stations

3. ProcessingServer stands for the Processing Server

4. ProtectionServer stands for the Licensing Server

Example:

Setup.exe /qn /L1049 /vADDLOCAL=ApplicationServer,WebStations

This set of commands will install the Application Server and web stations and Russian will be used as
the GUI language.

Removing ABBYY FlexiCapture servers in silent mode

Msiexec /x {product ID}

You can find out your product ID in this registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall (the product ID can be
found in the key that corresponds to the name of the product). Alternatively, execute this command: 

wmic product where “Name like ‘%FlexiCapture%’” get Name, Version, IdentifyingNumber

Installing stations using the command line 

By default, all the ABBYY FlexiCapture stations will be installed. For the name of the Licensing Server,
the setup program will specify the name of the computer from which the stations are being installed (in
the case of local installation, localhost will be specified). Network Service will be specified as the user of
the Processing Station. The interface language will be either English or the language specified in the
regional settings of the operating system.

Run the setup.exe file located in the administrative installation folder using the command line options
described below.

Advertise installation

For advertise installation, type:

Setup.exe /j

The program icon will appear in the Start menu of the workstation. Clicking this icon automatically
installs the pro-gram in the default configuration.

Silent installation

In the case of silent installation, no setup dialog boxes are displayed and the program is installed from
the server in the default configuration.

Setup.exe/qn

Change “/qn” to “/qb” if you want an installation progress bar to be displayed. No other dialog boxes will
be displayed.
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Additional command line options

/L<language code> disables the automatic selection of the GUI language and installs the program with
the interface language of your choice.

The following language code values can be specified:

1033 English

1049 Russian

/V<command line> passes the command line directly to msiexec.exe. The <command line> string can
be replaced with the following commands:

· INSTALLDIR=”<destination>” – the path to the folder where the ABBYY FlexiCapture stations
should be installed

· STATIONS=0,1,2,3,4,5,6 – the list of stations to install. The numbers 0 to 6 correspond to the
following stations:

0 – Scanning Station

1 – Processing Station

2 – Verification Station

3 – Data Verification Station

4 – Project Setup Station

5 – FlexiLayout Studio

6 – FormDesigner

· ACCOUNTTYPE=Custom, LOGIN=user name, PASSWORD=password.

You can specify an account under which to run the Processing Station service.

Example:

Setup.exe /qn /L1049 /v INSTALLDIR=”D:\FC12” STATIONS=1,4 ACCOUNTTYPE=Custom LOG-
IN=Domain\UserLogin PASSWORD=PSWD

This set of commands will install the Processing Station and the Project Setup Station into the D:\FC12
folder and Russian will be used as the GUI language. The Processing Station service will run under the
account Domain\UserLogin and the password will be PSWD.

PROTECTIONSERVER=ServerName – the name of the Licensing Server

Removing ABBYY FlexiCapture stations in silent mode

Msiexec /x {product ID}

You can find out your product ID in this registry key:

· For a 32-bit system
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
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· For a 64-bit system
HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

The product ID can be found in the key that corresponds to the name of the product). Alternatively,
execute this command:

wmic product where “Name like ‘%FlexiCapture%’” get Name, Version, IdentifyingNumber

Setup
After you install the server components, the License Manager utility and the Administration and
Monitoring Console will be started automatically. In the License Manager, click the Activate License...
button to activate your serial number). The Administration and Monitoring Console is where you set up
ABBYY FlexiCapture.

 Note

If you see an error message in the Administration and Monitoring Console, open the IIS Manager
console (click Start → Control Panel → Administrative Tools → Internet Information Services
(IIS) Manager). If the server is stopped, select Start on the Manage Server menu. In a similar
fashion, check that Default Web Site is running.

Creating a database
The first thing you need to do is create a database. 

Note: Depending on your setup, you may need to create a new database or connect to an existing
database.

To create a new database:

1. On the computer where the Application Server is installed, open the Administration and Monitoring
Console and click Service → Application Server to open the page
http://<server_name>/FlexiCapture12/Monitoring/#Settings/DbConn under the Windows
administrator account:

2. Click the Create New Database button.
 Note 
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If you are already connected to another database, you will need to close the existing sessions prior
to creating a new database. If, for some reason, this is not possible or necessary,  add the following
key into the web.config file that is located at <IIS Root Directory (the default location is "C:
\inetpub\wwwroot")>\<FlexiCapture12\Monitoring>:

<appSettings>
<add key="IgnoreCurrentSessions" value="true"/> 
</appSettings>

In this case, a new database will be created without a warning about existing sessions. In the old
database, all sessions are preserved. By default, the key is set to False and you will be prompted to
close the sessions when creating a new database.

3. The database creation page will open:

On this page, specify the following:

o The name of the Microsoft SQL Server instance in the format <server name>\<instance name>

o A name for the new database. Note the limitations imposed by Microsoft SQL Server on
database names (see this Microsoft website for details)

o A user account that has DBA permissions for Microsoft SQL Server
 Note

1. If Microsoft SQL Server is installed on a different computer than the Application Server, then
Database Server Authentication must be used to connect to the database server. 

2. We recommend choosing the TCP/IP protocol rather than Named Pipes to communicate with
the database server (the protocol is specified when you configure the Microsoft SQL Server
client, which is installed on the computer hosting the Application Server).

http://msdn.microsoft.com/en-us/library/ms175874.aspx
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o Select the Use external file storage option and specify the path to the file store. The file store
stores binary data, such as images to be processed, project settings, captured data, etc. The
speed of communication between the Application Server and the file store  greatly affects the
overall performance of ABBYY FlexiCapture. For this reason, we recommend placing the file
store on the same disk as the Application Server.

 Note

To achieve maximum performance in enterprise environments, we recommend using a fail-safe
disk, RAID configuration, or high-performance external storage solutions. When using a high-
performance disk, be sure to place the file store on the same physical disk where you keep the IIS
temporary folders.

Important!  A file store can only be created when creating a database and cannot be created later
while processing documents with ABBYY FlexiCapture. You also won't be able to disconnect the file
store you connected when creating the database.

 Note

If no file store is used, all project files are stored in the database. Note, however, that this approach
is only feasible for small projects with low processing volumes. While storing project files in the
database makes it easier to back up and recover your data, the size of the database may become
unacceptably large, causing performance degradation.

You must add the file store to the exceptions of your anti-virus software and the Windows
search indexing service.

o Use the Test Connection button to check the entered values. If the test is successful, click OK.
 Note

If you encounter authentication problems when testing the connection, check to make sure that 
Mixed Authentication Mode is enabled for Microsoft SQL Server ("SQL Server and Windows
authentication").
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When you create a database, the following settings will be enforced:

1. If Database Server Authentication is used, the database is created under the user account
specified on the Service → Application Server page of the Administration and Monitoring
Console. If Windows authentication is used, the database is created under the user account
under which the browser with the Service → Application Server page is running.

To create a database in Microsoft SQL Server, the user must have the following permissions:

a. CREATE DATABASE, CREATE ANY DATABASE or ALTER ANY DATABASE to create a
database

b. ALTER ANY LOGIN to create a new user

c. db_accessadmin and db_securityadmin permissions to the new database to provide
db_owner permissions to the user under whose account the Application Server is running.
Under this account, first the Description.sql and then the DBInitFill.sql script will be
executed. The scripts are located on the computer where the Application Server is
installed at <IIS Root Directory (the default location is “C:\inetpub\wwwroot”)
>\FlexiCapture12\Server. The first script creates a database and the second populates it
with data. The Upgrade*.sql files, which can be found in the same folder, are not used
when creating a new database.

2. If Microsoft SQL Server is used, the account under which the FlexiCapture 12 Web Services
pool is running on the Application Server is added onto the database server (by default, the
pool is running under the Network Service user account).

3. db_owner permissions to the FlexiCapture database created in step 1 are assigned to the
user account created in step 2 (if Microsoft SQL Server is used). All subsequent interaction
with the database will be carried out under the user account created in step 2. The account
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used for creating the database in step 1 can be deleted from the database server if
necessary.

4. Once the database is created, the user name and the temporary password password will be
displayed. 

Important! The user will need to change the temporary password on the login page
(http://<server_name>/FlexiCapture12/Login). Once the temporary password is changed, the user will be
redirected to the Administration and Monitoring Console. 

5. The user that creates the database automatically gets administrative privileges. The Administrator
also has the permissions to change the settings of the Application Server, upload projects, grant
access permissions for projects, create new users, and manage their roles and access
permissions. The Administrator can grant the Administrator role to another user and delegate
further configuration of the system to that user. The user that creates the database cannot be
deprived of the Administrator role, neither can that user’s account be deleted.

Connecting to an existing database
Instead of creating a new database, the administrator may need to connect to an existing database (e.g.
if the connection settings have been changed).

Note: For databases created in earlier versions of ABBYY FlexiCapture, see Upgrading databases and
projects created in an earlier version of the program.

To connect to an existing database, do the following:

1. On the computer where the Application Server is installed, open the Administration and Monitoring
Console and click Settings → Application Server to open the page
http://<server_name>/FlexiCapture12/Monitoring/#Settings/DbConn under the Windows
administrator account.
If the Application Server is already connected to a database, start at step 4. 

2. Click Connect to Existing Database.

3. In the form that opens, complete the following fields: the name of the Microsoft SQL Server
instance, the name of the existing database, the user that administers the database server, the
path to the file store (if any). 

4. Use the Test Connection button to check the entered values. If the test is successful, click OK.

5. Now your server is connected to the database. If an Upgrade link is displayed on the  Settings →
Application Server page next to the database version, then you should upgrade the database
before you proceed. 

6. If ABBYY FlexiCapture authentication has never been used for this database,  to the user under
whose account the Administration and Monitoring Console is running will be issued the temporary
password password.

Processing Server setup
To set up the Processing Server, complete the following steps:

1. Assign the Processing Server role to the user under whose account the Processing Server is
running. 
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By default, the Processing Server is installed on the same computer as the Application Server
and is started under the Network Service user account. In this case, the role is assigned to the
Processing Server automatically and this step can be skipped.
If the Processing Server role is not assigned automatically, grant the necessary permissions to
the Processing Server on the  Settings → Users page of the Administration and Monitoring
Console.
If the Processing Server is installed on a computer other than the computer with Application
Server and is running under the Network Service user account, the user will be displayed as
<Domain>\<Machine Name>$ in the Administration and Monitoring Console. If the Processing
Server service is running under a different user, it  assign Processing Server the role to that user.

2. Start the Processing Server Monitor (click Start → All Programs → ABBYY FlexiCapture 12
Servers → Processing Server).

3. In the Processing Server Monitor, click Actions → Properties and in the dialog box that opens,
specify the address of the Application Server (e.g. http://ApplicationServer). If the Processing
Server and the Application Server are installed on the same computer, the address of the
Application Server will be specified automatically. 

4. Click  to start the Processing Server.

5. Add Processing Stations. To do this, select Stations in the tree and click  . In the dialog box
that opens, select desired stations based on the names of their computers or click Browse... to
find stations on the network. After adding a station, you specify its parameters in the Station
Properties dialog box (click Actions   → Properties). The station will be started automatically
(this will take about a minute). If the station requires lengthy setup or you do not want to start the
station, clear the Start automatically option in the station properties.
To start desired stations manually, select them in the Processing Server Monitor main window

and click . 

Note: We do not recommended installing the Processing Station on the computer where the
FlexiCapture servers are installed as it will degrade server performance.

6. If required, specify processing settings for your project on the Project Setup Station (the settings
you specify will apply to batches of the Default type). To specify processing settings, click Project
  → Project Properties... and then click the Workflow tab. If your project contains various batch
types, specify workflow settings for each. To do this, click Project  → Batch Types..., then select
a batch type, click  Edit... and in the dialog box that opens click the Workflow tab.

Creating and opening projects
For ABBYY FlexiCapture Operators to be able to work on the same project(s) together, the project(s)
must be uploaded to the Application Server. To upload a project to the server, the user must have the
role of Administrator. 

To upload a project to the server, open the Project Setup Station and do one of the following: 

· Create a new project (click File  → New project…). Create or import at least one Document
Definition (click Project → Document Definitions).

· Open a sample project from %Public%\ABBYY\FlexiCapture\12.0\Samples.
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· Open a project created in an earlier version of ABBYY FlexiCapture.

· Create a new project. Make sure that your project has at least one correct and added Document
Definition for which export settings have been specified. 

Next, upload your project o the Application Server (click  File → Upload Project to Server… and in the
dialog box that opens, specify the URL server in the format http://<server name> and authentication
method).

Note:  When uploading a local project to the Application Server, a new project that is identical to the
local one is created on the server. The newly created project contains the same Document Definitions,
batch types, import sources, and project settings. The working batches with the images are copied to
the server. Test batches (they are created for each user) are accessible both from the local and from
the server project. 

Managing Your Licenses
The License Server of ABBYY FlexiCapture 12 includes the License Manager, an application for adding
and activating licenses and viewing license parameters. To open the License Manager, open the Start
menu and click All Programs → ABBYY FlexiCapture 12 Servers → FlexiCapture 12 License
Manager.

An ABBYY FlexiCapture distribution kit can include one of two types of protection keys:

· A hardware protection key (USB dongle)

· A software protection key (serial number)

If you have been issued with a software protection key, you will need to activate it in the Activation
Wizard before you can use it. To open the Activation Wizard, click the Activate License… button in
the License Manager. The activation technology limits the number of ABBYY FlexiCapture 12 copies that
can be used and prevents multiple installations of the same licensed copy.

Important! The number of times a license can be activated is limited. Each time a license is
activated, the number of remaining activations goes down, and each time a license is deactivated the
number of remaining activations goes up.

License activation
The Activation Wizard is a dialog box that provides a simple interface for activating ABBYY
FlexiCapture. During the activation process, the Activation Wizard generates a Product ID out of all the
information that is required for activation and sends the Product ID to ABBYY. This activation information
does not include any private data about you or your computer that could be used to identify you.

To activate your license, complete the following steps:

1. Provide your serial number (24 characters) and click Next.

2. Select an activation method: 

· via Internet (recommended) 
FlexiCapture will be activated automatically in just a few seconds. This method requires an
Internet connection.
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· by e-mail 
You will be prompted to send an automatically generated e-mail message containing activation
information to ABBYY. Do not make any changes to the title and body of the message to ensure a
prompt reply.

· by e-mail from another computer 
You will be prompted to send an e-mail message with generated activation information to ABBYY.
Use this method if the Licensing Server is not connected to the Internet and cannot send e-mails.

Note: If you have already received a license file in response to an e-mail request, click Load
activation file and specify the path to the license file (*.ABBYY.License).

3. Click Next to activate your license.

After the activation process is completed, you will be able to run ABBYY FlexiCapture 12 on the server.

Note: If you reinstall ABBYY FlexiCapture 12, you will not have to activate it again. The FlexiCapture
stations will automatically connect to the Licensing Server and use the existing license.

The Processing Server, Project Setup Station, and Verification Stations connect to the Licensing Server
directly using the address stored in the LicensingSettings.xml file in the FlexiCapture installation folder.
You can find this address in the ServerAddress tag of the MainNetworkLicenseServer attribute. If you
install the Licensing Server on a different computer, you will need to activate your licenses again (if you
are using license files) and change the address of the Licensing Server in the LicensingSettings.xml
files on the stations.

All other stations, including remote stations, web stations, Scanning Stations and Data Verification
Stations will receive licensing information from the Application Server.

Note: The Processing Server facilitates interactions between the Licensing Server and the Application
Server, so you will not be able to complete the activation process unless the Processing Server is
running and connected to the Application Server.

License parameters
The License Manager window is split into two parts:

· Licenses contains a list of installed licenses.

· License Parameters displays the parameters of the selected license.
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Important license details, such as its date of expiration and the number of remaining pages, are
displayed on the Summary page of the Administration and Monitoring Console if the Processing Server
is running. If it is not, the message "Data could not be accessed" is displayed instead. License
parameters can only be viewed by the Administrator.

To make licenses easier to monitor, you can set up automatic e-mail notifications about the statuses of
licenses to be sent to specific users. To do this, open the Administration and Monitoring Console, click 
Settings → E-mail notifications and specify the notification settings. For details, see the online help of
the Administration and Monitoring Console.
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Setting up e-mail notifications
You can use the Administration and Monitoring Console to set up e-mail notifications in order to help
keep track of licenses and user requests for permissions.

Notifications can be sent when the following event occur:

· New permission request 
A user made a permission request.

· The license is running out of pages 
The license has less pages than the specified percentage.

· The license will expire soon 
The license will expire in the specified number of days.

Note: If you replace a license that is about to expire with a license that expires in less than the
specified number of days, the new license will not trigger a second notification.

Complete the following steps to start the notification service:

1. Make sure that the Processing Server is running.

2. Open the Administration and Monitoring Console, click Settings → SMTP-settings and specify
the connection settings for the SMTP server:

· SMTP-server 
The address of the notification server (e.g. smtp.email.com).

· SMTP-port 
The port number. By default, port 25 is used for unencrypted connections and port 465 is used
for SSL-encrypted connections.

· SMTP-login
The name of the mail box that will be used for sending the notifications.

· Password 
The password used for accessing the e-mail server.

· If you want to encrypt data using the SSL protocol, enable the Use SSL option.

3. Open the Settings → E-mail notifications page, select one or more events and notification
recipients.

4. The text in the default messages cannot be changed, but you can type additional text and change
the subject.

5. Click Save.

Now when the selected events occur, notifications will be automatically sent to the recipients you
specified.

Example of a notification setup that uses Gmail
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The screenshot below shows a notification setup where Gmail is used as the e-mail server:

Important! Make sure that the specified port is not blocked by your firewall.

Upgrading from ABBYY FlexiCapture 10 and 11
ABBYY FlexiCapture 12 can be installed on the same computer where ABBYY FlexiCapture 10 or 11 is
already installed.  You cannot use the setup wizard to upgrade your ABBYY FlexiCapture 10 or 11 to
version 12.
You cannot use your ABBYY FlexiCapture 10 and 11 serial numbers to run ABBYY FlexiCapture 12.

You can use ABBYY FlexiCapture and ABBYY FlexiLayout projects and FlexiLayouts created in earlier
versions of the program. If you have documents already loaded into the system, we recommend that
you first complete the processing of these documents and only then migrate to ABBYY FlexiCapture 12.
When you open an ABBYY FlexiCapture and ABBYY FlexiLayout project created in an earlier version of
the program, it will be converted to the ABBYY FlexiCapture 12 format. Once a project is converted, it
can no longer be opened in the earlier versions. 

Note: After you install ABBYY FlexiCapture 12, it will become the default application for all FlexiCapture
and FlexiLayout Studio projects (*.fcproj and *.fsp files respectively), even if ABBYY FlexiCapture 11 or
10 is installed on your computer. To open a project in ABBYY FlexiCapture 11 or 10, launch ABBYY
FlexiCapture or ABBYY FlexiLayout Studio via the Windows Start menu and click File → Open
Project....
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Updating projects created in a standalone edition of ABBYY
FlexiCapture (*.fcproj)
Projects created in a standalone edition of ABBYY FlexiCapture are stored in the file system. You can
open projects created in ABBYY FlexiCapture 10 or 11 (.fcproj) and use them in ABBYY FlexiCapture 12.
Please note the following: 

1. After you open an .fcproj in ABBYY FlexiCapture 12, you will no longer be able to open it in ABBYY
FlexiCapture 10 or 11. If you think you will need to open an .fcproj in ABBYY FlexiCapture 10 or 11 in
the future, create a copy of that project before opening it in ABBYY FlexiCapture 12. 

2. When you open an ABBYY FlexiCapture 10 or 11 project in ABBYY FlexiCapture 12, you may need to
delete all the processing results and analyze all the pages once again. 

Note: You may continue using old projects without recognizing the documents again, but some data
may be displayed incorrectly. For instance, if there are format errors in an ABBYY FlexiCapture 10 or 11
project, they will not be displayed in the document window in the same way as such errors are displayed
in ABBYY FlexiCapture 12.

Updating projects and databases created in a distributed edition of
ABBYY FlexiCapture
A distributed edition of ABBYY FlexiCapture works with projects that are stored in the database on the
Application Server. 

There are several ways to migrate from an earlier version to ABBYY FlexiCapture 12:  

· Connecting to a database created in an earlier version of ABBYY FlexiCapture;

· Moving projects created in an earlier version of ABBYY FlexiCapture to a new database
(recommended).

Important! Before upgrading to ABBYY FlexiCapture 12, be sure to complete the processing of any
documents that are still being processed by your previous version of ABBYY FlexiCapture, otherwise all
these documents will be lost.
Connecting to a database created in an earlier version of ABBYY FlexiCapture  

Once ABBYY FlexiCapture 12 servers are installed, you can use the Administration and Monitoring
Console to connect to the database and file storage location that were used by your earlier version of
ABBYY FlexiCapture. Then update the database to the new version and continue working with it. If you
choose this method, you will no longer be able to work with your earlier version of ABBYY FlexiCapture. 

Note: After you complete the steps described in this section, you will no longer be able to use your
earlier version of ABBYY FlexiCapture. For this reason, we recommend that you back up your old
database and file storage location before you processed with these steps. You can then use these back-
up copies to restore the operation of your earlier version of ABBYY FlexiCapture if any problems occur. 

To connect to the old database:

1. Complete the processing of documents with your earlier version of ABBYY FlexiCapture:

a. Complete the processing of all the batches that have already been registered in the system.

b. Start the Administration and Monitoring Console.
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c. In the Administration and Monitoring Console, select Settings → Cleanup to remove any
redundant data.

d. Select Monitoring → Sessions to make sure there are no open sessions. If you see any
open sessions, close the clients where this sessions are running. 

Note: If, for some reason, you cannot close all of the clients with open sessions, disconnect the
Application Server from the database. To achieve this, clear the value of
HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\10.0 (or 11.0)\WebServices
“DBConnectionString” in the Windows registry and restart the World Wide Web Publishing Service in
the services.msc snap-in. Once you complete this step, you will no longer be able to use your earlier
version of ABBYY FlexiCapture.

2. Connect to the database of your earlier version of ABBYY FlexiCapture:

a. Start the Administration and Monitoring Console of ABBYY FlexiCapture 12, select Settings →
Application server, and click the Connect to existing database button.

b. Specify the name of the database server, the name of the database, and the path to the file
storage location which were used by your earlier version of ABBYY FlexiCapture and click OK.
See Connecting to an existing database for more information about connecting to an existing
database.

3. Update the database to the version used by ABBYY FlexiCapture 12:

a. After you connect to the database of your earlier version of ABBYY FlexiCapture, you will see
an Upgrade link next to the name of the database on the page Settings → Application
server. Click this link. The database will be updated to the version used by ABBYY
FlexiCapture 12. Once you complete this step, you will no longer be able to use the database
in earlier versions of ABBYY FlexiCapture.

4. Update the projects on the Application Server of ABBYY FlexiCapture 12:

a. Start the Project Setup Station of ABBYY FlexiCapture 12 and open all of the projects on the
Application Server, one by one. When you open an old project, it will be updated to the version
used by ABBYY FlexiCapture 12.

Moving projects created in an earlier version of ABBYY FlexiCapture to a new database  

If you wish to keep your earlier version of ABBYY FlexiCapture and at the same time use its projects in
ABBYY FlexiCapture 12, you need to create a new database in ABBYY FlexiCapture 12 and move the
required projects to this database. 

Proceed as follows: 

1. Export the projects created in your earlier version of ABBYY FlexiCapture from the Application
Server to the file system:

a. On the Project Setup Station of your earlier version of ABBYY FlexiCapture, open the projects
on the Application Server, one by one, and use the Project → Export Project command in
the main menu to export the projects to the file system. This will only export the projects, the
documents will not be exported. Therefore, be sure to complete the processing of the
documents in your earlier version of ABBYY FlexiCapture; 

2. Create a new database in ABBYY FlexiCapture 12:
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a. In the Administration and Monitoring Console of ABBYY FlexiCapture 12, create a new
database and specify the path to the new file storage location (see Creating a database for
detailed instructions); 

3. Update the projects to the version used by ABBYY FlexiCapture 12 and upload them onto the
Application Server:

a. On the Project Setup Station of ABBYY FlexiCapture 12, open the exported *.fcproj projects,
one by one. When you open an old project, it will be updated to the version used by ABBYY
FlexiCapture 12.

b. Once a project has been updated, upload it onto the Application Server by selecting File →
Upload Project to Server in the main menu of the Project Setup Station. For more
information about uploading projects to the Application Server, see the Creating and opening
projects section.

Updating ABBYY FlexiLayout Studio 10 or 11 projects (*.fsp)
All FlexiLayout Studio 10 or 11 projects can be opened in FlexiLayout Studio 12. Please note the
following: 

1. It is impossible to open an .fsp-project in ABBYY FlexiLayout Studio 10 or 11 once it was opened
in ABBYY FlexiLayout Studio 12, so you should create a copy of the project before opening it in
ABBYY FlexiLayout Studio 12 if you still need to open it in ABBYY FlexiLayout Studio 10 or 11. 

2. After opening a FlexiLayout Studio 10 or 11 project in ABBYY FlexiLayout Studio 12 you may need
to delete all processing results and analyze all pages once again. 

3. Due to changes in FlexiLayout language some compilation errors may occur. In this case you will
need to correct errors and re-compile FlexiLayouts. 

Using FlexiLayouts (*.afl) created in ABBYY FlexiLayout 10 or 11
FlexiLayouts compiled in ABBYY FlexiLayout 10 or 11 can be loaded into ABBYY FlexiCapture 12. 

Sometimes due to changes in FlexiLayout language some compilation errors may occur. In this case
open the *.fsp project in ABBYY FlexiLayout Studio 12, correct the errors and re-compile FlexiLayouts. 
See Updating ABBYY FlexiLayout Studio 10 or 11 projects (*.fsp) for detailed instructions.
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